System Requirements

The ProStudioMasters Download Manager (DLM) can be installed on computers running macOS and Windows, as well as a number of Linux operating systems.

The DLM cannot currently be installed on mobile devices such as phones or tablets.


Minimum System Requirements

macOS Windows Linux
10.10 Yosemite or higher Windows 7 or higher See notes below

On any operating system, we recommend ensuring that there is enough disk space available to store purchased downloads – at least 25 GB – as well as having 4GB total RAM.


Note for macOS users

  • Your security settings must "Allow applications downloaded from Mac App Store and identified developers" in order for the ProStudioMasters.app to run. 
  • You can adjust these security settings via the System Preferences application, and clicking on the "Security & Privacy" icon. The "Allow applications downloaded from" section is on the lower half of the "General" tab.

Note for Linux users

  • Users have reported success on Ubuntu 18.04.4 LTS, Mint 19.3, and Fedora 31, as well as Debian and Manjaro distributions
  • AppImage should work on most modern 64-bit distribution
  • If you encounter issues, you likely need to set permissions for the AppImage to run as an executable
    • To do so, right click on the AppImage, open "Properties", click on the "Permissions" tab, and enable "Allow executing file as program"


Note for users on legacy operating systems
For the moment, DLM version 2.0.05 continues to function on 32-bit systems and older editions of Windows, including Windows XP. However, it is offered only as unsupported legacy software, with no fixes / updates planned.

Version 2.0.05 can be obtained via the following links:

Windows: http://download.prostudiomasters.com/win/ProStudioMasters-2.0.05.exe

macOS: http://download.prostudiomasters.com/mac/ProStudioMasters-2.0.05.dmg

Still need help? Contact Us Contact Us